<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"    "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"> 
<html xmlns="http://www.w3.org/1999/xhtml" lang="en" xml:lang="en" dir="ltr" id="html-main">

<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />

  <title>Celebrating The Life of Neil V.I.M. Chan, A.A. | Guyana Graphic</title>
  <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<meta property="fb:app_id" content="158651424149318"/>

<meta property="og:title" content="Celebrating The Life of Neil V.I.M. Chan, A.A."/>
<meta property="og:site_name" content="Guyana Graphic"/>

<link rel="shortcut icon" href="/sites/default/files/analytic_favicon.ico" type="image/x-icon" />
  <link type="text/css" rel="stylesheet" media="all" href="/modules/poll/poll.css?Z" />
<link type="text/css" rel="stylesheet" media="all" href="/modules/aggregator/aggregator.css?Z" />
<link type="text/css" rel="stylesheet" media="all" href="/modules/calendar/calendar_multiday/calendar_multiday.css?Z" />
<link type="text/css" rel="stylesheet" media="all" href="/modules/cck/theme/content-module.css?Z" />
<link type="text/css" rel="stylesheet" media="all" href="/modules/ckeditor/ckeditor.css?Z" />
<link type="text/css" rel="stylesheet" media="all" href="/modules/colorbox/styles/default/colorbox_default_style.css?Z" />
<link type="text/css" rel="stylesheet" media="all" href="/modules/ctools/css/ctools.css?Z" />
<link type="text/css" rel="stylesheet" media="all" href="/modules/date/date.css?Z" />
<link type="text/css" rel="stylesheet" media="all" href="/modules/date/date_popup/themes/datepicker.css?Z" />
<link type="text/css" rel="stylesheet" media="all" href="/modules/date/date_popup/themes/jquery.timeentry.css?Z" />
<link type="text/css" rel="stylesheet" media="all" href="/modules/fbconnect/fbconnect.css?Z" />
<link type="text/css" rel="stylesheet" media="all" href="/modules/filefield/filefield.css?Z" />
<link type="text/css" rel="stylesheet" media="all" href="/modules/img_assist/img_assist.css?Z" />
<link type="text/css" rel="stylesheet" media="all" href="/modules/jquerymenu/jquerymenu.css?Z" />
<link type="text/css" rel="stylesheet" media="all" href="/modules/node/node.css?Z" />
<link type="text/css" rel="stylesheet" media="all" href="/modules/sharebar/css/sharebar.css?Z" />
<link type="text/css" rel="stylesheet" media="all" href="/modules/simplenews/simplenews.css?Z" />
<link type="text/css" rel="stylesheet" media="all" href="/sites/all/libraries/superfish/css/superfish.css?Z" />
<link type="text/css" rel="stylesheet" media="all" href="/sites/all/libraries/superfish/css/superfish-vertical.css?Z" />
<link type="text/css" rel="stylesheet" media="all" href="/sites/all/libraries/superfish/css/superfish-navbar.css?Z" />
<link type="text/css" rel="stylesheet" media="all" href="/modules/system/defaults.css?Z" />
<link type="text/css" rel="stylesheet" media="all" href="/modules/system/system.css?Z" />
<link type="text/css" rel="stylesheet" media="all" href="/modules/system/system-menus.css?Z" />
<link type="text/css" rel="stylesheet" media="all" href="/modules/user/user.css?Z" />
<link type="text/css" rel="stylesheet" media="all" href="/modules/video_filter/video_filter.css?Z" />
<link type="text/css" rel="stylesheet" media="all" href="/modules/forum/forum.css?Z" />
<link type="text/css" rel="stylesheet" media="all" href="/modules/cck/modules/fieldgroup/fieldgroup.css?Z" />
<link type="text/css" rel="stylesheet" media="all" href="/modules/views/css/views.css?Z" />
<link type="text/css" rel="stylesheet" media="all" href="/modules/image/contrib/image_attach/image_attach.css?Z" />
<link type="text/css" rel="stylesheet" media="all" href="/sites/all/libraries/superfish/style/blue.css?Z" />
<link type="text/css" rel="stylesheet" media="all" href="/modules/tablefield/tablefield.css?Z" />
<link type="text/css" rel="stylesheet" media="all" href="/themes/analytic/style.css?Z" />
<link type="text/css" rel="stylesheet" media="all" href="/themes/analytic/local.css?Z" />
  <script type="text/javascript" src="/sites/default/files/js/js_ba0766164f1299f66e0fb9cfa49827a1.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
jQuery.extend(Drupal.settings, { "basePath": "/", "colorbox": { "transition": "elastic", "speed": 350, "opacity": "0.85", "slideshow": false, "slideshowAuto": false, "slideshowSpeed": 2500, "slideshowStart": "", "slideshowStop": "", "current": "{current} of {total}", "previous": "« Prev", "next": "Next »", "close": "Close", "overlayClose": true, "maxWidth": "100%", "maxHeight": "100%", "image_derivative": "thickbx size" }, "fbconnect": { "user_pictures": "allow", "language_code": "en_US", "app_id": "158651424149318", "debug": 0, "connect_js": "document.location.protocol + \'//connect.facebook.net/en_US/all.js\'", "loginout_mode": "manual", "invite_name": "Guyana Graphic", "fast_reg_mode": 1, "fbuid": null, "user": { "uid": 0, "fbuid": null } }, "googleanalytics": { "trackOutbound": 1, "trackMailto": 1, "trackDownload": 1, "trackDownloadExtensions": "7z|aac|arc|arj|asf|asx|avi|bin|csv|doc(x|m)?|dot(x|m)?|exe|flv|gif|gz|gzip|hqx|jar|jpe?g|js|mp(2|3|4|e?g)|mov(ie)?|msi|msp|pdf|phps|png|ppt(x|m)?|pot(x|m)?|pps(x|m)?|ppam|sld(x|m)?|thmx|qtm?|ra(m|r)?|sea|sit|tar|tgz|torrent|txt|wav|wma|wmv|wpd|xls(x|m|b)?|xlt(x|m)|xlam|xml|z|zip" }, "superfish": { "1": { "id": "1", "sf": { "animation": { "opacity": "show", "width": "show" }, "speed": "fast", "autoArrows": true, "dropShadows": false, "disableHI": false }, "plugins": { "smallscreen": { "mode": "window_width", "title": "Primary links" }, "supposition": true, "bgiframe": false, "supersubs": { "minWidth": "12", "maxWidth": "27", "extraWidth": 1 } } } }, "CToolsUrlIsAjaxTrusted": { "/guyana/announcements/deaths-obituaries/celebrating-life-neil-vim-chan-aa": true }, "sharebar": { "cls": "#sharebar" } });
//--><!]]>
</script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
var BASE_URL = "/";
//--><!]]>
</script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
(function ($) {
Drupal.behaviors.jq_maphilight = function(context, settings) {
$.fn.maphilight.defaults = {
fill: true,
fillColor: '000000',
fillOpacity: 0.2,
stroke: true,
strokeColor: 'ff0000',
strokeOpacity: 1,
strokeWidth: 2,
fade: true,
alwaysOn: false,
neverOn: false,
groupBy: false};
$('img[usemap]').maphilight();
}})(jQuery);
//--><!]]>
</script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
jQuery(document).ready(function($) { $('.sharebar').sharebar({horizontal:'TRUE',swidth:'70',minwidth:1300,position:'right',leftOffset:5,rightOffset:400}); });
//--><!]]>
</script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
(function(i,s,o,g,r,a,m){i["GoogleAnalyticsObject"]=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,"script","//www.google-analytics.com/analytics.js","ga");ga("create", "UA-28809753-1", { "cookieDomain": "auto" });ga("send", "pageview");
//--><!]]>
</script>
  <script type="text/javascript"> </script>
  <script src="/sites/all/libraries/ckeditor/ckeditor.js"></script>
  <meta name="google-site-verification" content="7mAX_P1gZ7wDMB2AYAhXw3R6me2X9bvvCF4uEgMTueU" />
<meta name="google-translate-customization" content="af7c5129080eb64c-c46bc66582ebddb8-g006c0565d55b92fb-15">
<meta name="description" content="GuyanaGraphic.com delivers the latest breaking news and information on the latest top stories, weather, business, entertainment, politics, and more. For in-depth coverage, GuyanaGraphic.com provides special reports, video, audio, photo galleries, and interactive guides.">
<meta name="keywords" content="Guiana,Guyana,Guiana Graphic,Guyana Graphic,Sunday Graphic,Guyanese Beauties,GuyanaGraphic.com,Anything Guyanese,Guyanese United,news,breaking news,world news,weather,business,money,sports,politics,law,technology,entertainment,education,travel,health,special reports,autos,developing story,news video,ICMBC">
</meta>
 
   
        </head>

    <body class="body-main georgia">	
	
<!-- / make-it-center --><div class="make-it-center">

<div class="top-menu clear-block">
    
  
  <!-- >>>>>>>> REMOVE THIS IF YOU WANT TO GET RID OF TOP LINKS (RSS, LOGIN, REGISTER | PROFILE) start-->  
  
  <div id="top-links">
    <ul class="top-links-ul">

 <li>  <div id="search-box">
    <form action="/guyana/announcements/deaths-obituaries/celebrating-life-neil-vim-chan-aa"  accept-charset="UTF-8" method="post" id="search-theme-form">
<div><div id="search" class="container-inline">
  <div class="form-item" id="edit-search-theme-form-1-wrapper">
 <label for="edit-search-theme-form-1">Search this site: </label>
 <input type="text" maxlength="128" name="search_theme_form" id="edit-search-theme-form-1" size="15" value="" title="Enter the terms you wish to search for." class="form-text" />
</div>
<input type="submit" name="op" id="edit-submit" value="Search"  class="form-submit" />
<input type="hidden" name="form_build_id" id="form-9hB-aH3Ketzw7-xUOTmmxjzwJg2B4mB0rgfL3vFDRM0" value="form-9hB-aH3Ketzw7-xUOTmmxjzwJg2B4mB0rgfL3vFDRM0"  />
<input type="hidden" name="form_id" id="edit-search-theme-form" value="search_theme_form"  />
</div>

</div></form>
  </div><!-- /search-box -->
  
</li>

 <class="block block-fboauth" id="block-fboauth-login">
      <li> <class="content"><a  class="facebook-action-connect" href="https://www.facebook.com/dialog/oauth?client_id=158651424149318&redirect_uri=http%3A%2F%2Fwww.guyanagraphic.com%2Ffboauth%2Fconnect&scope=email%2Cuser_about_me%2Cuser_birthday%2Cuser_education_history%2Cuser_hometown%2Cuser_relationship_details%2Cuser_location%2Cuser_religion_politics%2Cuser_relationships%2Cuser_website%2Cuser_work_history%2Cmanage_pages"><img src="http://www.facebook.com/images/fbconnect/login-buttons/connect_light_medium_short.gif" alt="" /></a></li>

   	
    	<li><a href="/user">Log in</a></li>
          
<li><SCRIPT>
		var mydate=new Date()
		var year=mydate.getYear()
		if (year < 1000)
		year+=1900
		var day=mydate.getDay()
		var month=mydate.getMonth()
		var daym=mydate.getDate()
		if (daym<10)
		daym="0"+daym
		var dayarray=new Array("Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday")
		var montharray=new Array("January","February","March","April","May","June","July","August","September","October","November","December")
		document.write("<small><font color='23749e' face='Arial'><b>"+dayarray[day]+", "+montharray[month]+" "+daym+", "+year+"</b></font></small>")
		</SCRIPT>

		    		</li>

    
	   
	
	</ul>
  </div>
  
  <!-- <<<<<<<< REMOVE THIS IF YOU WANT TO GET RID OF TOP LINKS (RSS, LOGIN, REGISTER) end -->

</div>

<!-- logo-container -->
<div id="logo-container">
 <table style="width: 100%" cellspacing="0" cellpadding="0" align="center" bgcolor="#D60000">
<tr>

	<td rowspan="2" style="width:30%" align="left">
		<span style="text-align: center; font-family: sans-serif; font-size: 12px;"><style="display: block !important; width: 180px; text-align: center; font-family: sans-serif; font-size: 12px;"><a href="http://www.wunderground.com/cgi-bin/findweather/getForecast?query=zmw:00000.1.81001&bannertypeclick=wu_bluestripes" title="Georgetown, Guyana Weather Forecast" target="_blank"><img src="http://weathersticker.wunderground.com/weathersticker/cgi-bin/banner/ban/wxBanner?bannertype=wu_bluestripes&airportcode=SYCJ&ForcedCity=Georgetown&ForcedState=Guyana&wmo=81001&language=EN" alt="Find more about Weather in Georgetown, GY" width="160" /></a><br><a href="http://www.wunderground.com/cgi-bin/findweather/getForecast?query=zmw:00000.1.81001&bannertypeclick=wu_bluestripes" title="Get latest Weather Forecast updates" style="font-family: sans-serif; font-size: 12px" target="_blank"></a></td>

	<td rowspan="2">
<div class="clear-block">
  <div id="logo-no-padding">
  
			 
            <div id="logo-picture">
            <a href="/" title="Home"><img src="/sites/default/files/analytic_logo.jpg" alt="Home" /></a>
            </div>
            	
	<a class="no_outline" href="  
  
  </div>
  </div>
</a></td>

  <td rowspan="2" style="width: 30%" align="right">

		    		
</td>
</td>
</tr>
<tr>
  <td rowspan="2" style="width: 30%" align="right"> 
	
<iframe src="//www.facebook.com/plugins/like.php?href=http%3A%2F%2Fwww.facebook.com/GuyanaGraphicLive&amp;send=true&amp;layout=standard&amp;width=285&amp;show_faces=false&amp;action=like&amp;colorscheme=light&amp;font&amp;height=25&amp;appId=158651424149318" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:250px; height:25px;" allowTransparency="false"></iframe>

           
<div id="google_translate_element"></div><script type="text/javascript">
function googleTranslateElementInit() {
  new google.translate.TranslateElement({pageLanguage: 'en', layout: google.translate.TranslateElement.InlineLayout.SIMPLE}, 'google_translate_element');
}
</script><script type="text/javascript" src="//translate.google.com/translate_a/element.js?cb=googleTranslateElementInit"></script>

</td>
</tr>
</table><!-- /logo-container -->

 

<!-- primary menu -->
<div class="rws-primary-menu clear-block">
   
 
          
   
     
  

  <!-- admin edit   -->
    <!-- admin edit   -->
  
  
  
    <!-- admin panel   -->
     <!-- / admin panel -->


</div>
<!--  /primary menu -->

  <div id="menu-region" class="region">
      <div class="block block-superfish" id="block-superfish-1">
       <div class="content"><ul id="superfish-1" class="sf-menu sf-primary-links sf-horizontal sf-style-blue sf-total-items-11 sf-parent-items-4 sf-single-items-7"><li id="menu-178-1" class="first odd sf-item-1 sf-depth-1 sf-no-children"><a href="/" title="">Headline News</a></li><li id="menu-179-1" class="middle even sf-item-2 sf-depth-1 sf-total-children-9 sf-parent-children-3 sf-single-children-6 menuparent"><a href="/guyana" title="">Guyana</a><ul><li id="menu-290-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="/guyana/government-links" title="">Government Links</a></li><li id="menu-291-1" class="middle even sf-item-2 sf-depth-2 sf-total-children-2 sf-parent-children-0 sf-single-children-2 menuparent"><a href="/guyana/history" title="">History</a><ul><li id="menu-1784-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/guyana/history/ww-i-and-ii-service-members" title="">WW I and II Service Members</a></li><li id="menu-1289-1" class="last even sf-item-2 sf-depth-3 sf-no-children"><a href="/guyana/history/monetary-denominations-guyana" title="">Monetary Denominations of Guyana</a></li></ul></li><li id="menu-784-1" class="middle odd sf-item-3 sf-depth-2 sf-total-children-1 sf-parent-children-0 sf-single-children-1 menuparent"><a href="/guyana/people-culture" title="">People and Culture</a><ul><li id="menu-1288-1" class="firstandlast odd sf-item-1 sf-depth-3 sf-no-children"><a href="/content/national-and-patriotic-songs-guyana" title="">National Songs</a></li></ul></li><li id="menu-780-1" class="middle even sf-item-4 sf-depth-2 sf-no-children"><a href="/guyana/regions" title="">Regions</a></li><li id="menu-761-1" class="middle odd sf-item-5 sf-depth-2 sf-total-children-3 sf-parent-children-0 sf-single-children-3 menuparent"><a href="/guyana/announcements" title="">Announcements</a><ul><li id="menu-762-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/guyana/announcements/births" title="">Births</a></li><li id="menu-763-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/guyana/announcements/weddings" title="">Weddings</a></li><li id="menu-764-1" class="last odd sf-item-3 sf-depth-3 sf-no-children"><a href="/guyana/announcements/deaths-obituaries" title="">Deaths &amp; Obituaries</a></li></ul></li><li id="menu-781-1" class="middle even sf-item-6 sf-depth-2 sf-no-children"><a href="/guyana/distinguished-guyanese" title="">Distinguished Guyanese</a></li><li id="menu-782-1" class="middle odd sf-item-7 sf-depth-2 sf-no-children"><a href="/guyana/notable-guyanese" title="">Notable Guyanese</a></li><li id="menu-783-1" class="middle even sf-item-8 sf-depth-2 sf-no-children"><a href="/guyana/people-search" title="">People Search</a></li><li id="menu-7705-1" class="last odd sf-item-9 sf-depth-2 sf-no-children"><a href="/guyana/bridge-road-closures" title="Bridge &amp; Road Closures">Bridge &amp; Road Closures</a></li></ul></li><li id="menu-180-1" class="middle odd sf-item-3 sf-depth-1 sf-no-children"><a href="/world" title="">World</a></li><li id="menu-182-1" class="middle even sf-item-4 sf-depth-1 sf-no-children"><a href="/business" title="">Business</a></li><li id="menu-181-1" class="middle odd sf-item-5 sf-depth-1 sf-no-children"><a href="/government-politics" title="">Government &amp; Politics</a></li><li id="menu-183-1" class="middle even sf-item-6 sf-depth-1 sf-no-children"><a href="/health" title="">Health</a></li><li id="menu-1132-1" class="middle odd sf-item-7 sf-depth-1 sf-total-children-1 sf-parent-children-1 sf-single-children-0 menuparent"><a href="/science-technology" title="">Science &amp; Technology</a><ul><li id="menu-1137-1" class="firstandlast odd sf-item-1 sf-depth-2 sf-total-children-6 sf-parent-children-1 sf-single-children-5 menuparent"><a href="/science-technology/aviation" title="">Aviation</a><ul><li id="menu-1143-1" class="first odd sf-item-1 sf-depth-3 sf-total-children-1 sf-parent-children-0 sf-single-children-1 menuparent"><a href="/science-technology/aviation/aircraft" title="">Aircraft</a><ul><li id="menu-1144-1" class="firstandlast odd sf-item-1 sf-depth-4 sf-no-children"><a href="/science-technology/aviation/aircraft/accidents" title="">Accidents</a></li></ul></li><li id="menu-1813-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/science-technology/aviation/guyanese-aircraft-maintenance-engineers" title="">Aircraft Maintenance Engineers</a></li><li id="menu-1281-1" class="middle odd sf-item-3 sf-depth-3 sf-no-children"><a href="/science-technology/aviation/guyanese-pilots" title="">Pilots</a></li><li id="menu-1145-1" class="middle even sf-item-4 sf-depth-3 sf-no-children"><a href="/science-technology/aviation/gac-employee-corner" title="">GAC Employee Corner</a></li><li id="menu-1146-1" class="middle odd sf-item-5 sf-depth-3 sf-no-children"><a href="/science-technology/aviation/history" title="">History</a></li><li id="menu-1147-1" class="last even sf-item-6 sf-depth-3 sf-no-children"><a href="/science-technology/aviation/news" title="">News</a></li></ul></li></ul></li><li id="menu-284-1" class="middle even sf-item-8 sf-depth-1 sf-no-children"><a href="/travel" title="">Travel</a></li><li id="menu-186-1" class="middle odd sf-item-9 sf-depth-1 sf-total-children-1 sf-parent-children-0 sf-single-children-1 menuparent"><a href="/sports" title="">Sports</a><ul><li id="menu-295-1" class="firstandlast odd sf-item-1 sf-depth-2 sf-no-children"><a href="/sports/guyanese-sports" title="">Guyanese in Sports</a></li></ul></li><li id="menu-197-1" class="middle even sf-item-10 sf-depth-1 sf-total-children-4 sf-parent-children-0 sf-single-children-4 menuparent"><a href="/edutainment" title="">Edutainment</a><ul><li id="menu-979-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="/edutainment/educational-apps" title="">Educational Apps</a></li><li id="menu-878-1" class="middle even sf-item-2 sf-depth-2 sf-no-children"><a href="/edutainment/guyanese-authors" title="">Guyanese Authors</a></li><li id="menu-287-1" class="middle odd sf-item-3 sf-depth-2 sf-no-children"><a href="/edutainment/guyanese-edutainment" title="Guyanese in Edutainment">Guyanese in Edutainment</a></li><li id="menu-1118-1" class="last even sf-item-4 sf-depth-2 sf-no-children"><a href="/guyanese-beauties" title="">Beauties</a></li></ul></li><li id="menu-875-1" class="last odd sf-item-11 sf-depth-1 sf-no-children"><a href="/live" title="Live Interactive Video Edutainment">LIVE</a></li></ul></div>
 </div>
  </div>
 
<!-- column-1 -->
<div class="column-1">  <div class="block block-on_the_web" id="block-on_the_web-web">
       <div class="content"><span class="on-the-web otw-twitter otw-0"><a href="https://twitter.com/GuyanaGraphic" title="Find Guyana Graphic on Twitter" target="_blank"><img src="/modules/on_the_web/images/sm/twitter.png" alt="Find Guyana Graphic on Twitter" title="Find Guyana Graphic on Twitter" width="32" height="32" /></a></span><span class="on-the-web otw-facebook otw-1"><a href="https://www.facebook.com/GuyanaGraphic" title="Find Guyana Graphic on Facebook" target="_blank"><img src="/modules/on_the_web/images/sm/facebook.png" alt="Find Guyana Graphic on Facebook" title="Find Guyana Graphic on Facebook" width="32" height="32" /></a></span><span class="on-the-web otw-youtube otw-2"><a href="https://www.youtube.com/user/guyanagraphic" title="Find Guyana Graphic on YouTube" target="_blank"><img src="/modules/on_the_web/images/sm/youtube.png" alt="Find Guyana Graphic on YouTube" title="Find Guyana Graphic on YouTube" width="32" height="32" /></a></span></div>
 </div>
<div id="block--0" class="block">

  <div class="content">
    <div style='text-align:center'><div class='adsense' style='display:inline-block;width:160px;height:600px;'>
<script type="text/javascript"><!--
google_ad_client = "ca-pub-9625100032439743";
/* 160x600 */
google_ad_slot = "9923029719";
google_ad_width = 160;
google_ad_height = 600;
//-->
</script>
<script type="text/javascript"
src="//pagead2.googlesyndication.com/pagead/show_ads.js">
</script>
</div></div>  </div>
</div>
  <div class="block block-imageblock" id="block-imageblock-4">
       <div class="content">  <div class="block-image">
    <a href="http://www.guyanagraphic.com/content/guyana-graphic-advertising" class="imageblock-link" target="_self"><img src="/sites/default/files/160x160.JPG" alt="" title="" width="161" height="162" class="imageblock-image" /></a>  </div>

</div>
 </div>
</div>
<!-- / column-1 -->





<!-- column-2 --><div class="column-2 
">


						        


<!-- PRINTING BLOCKS BEFORE THE CONTENT (with RED headers) -->
<!-- PRINTING BLOCKS BEFORE THE CONTENT (with RED headers) -->

<div id="content-top">  <div class="block block-imageblock" id="block-imageblock-37">
       <div class="content">  <div class="block-image">
    <a href="http://www.guyanagraphic.com/live" class="imageblock-link" target="_self"><img src="/sites/default/files/flashing-air-494.gif" alt="" title="" width="494" height="64" class="imageblock-image" /></a>  </div>

</div>
 </div>
</div>


		<div class="breadcrumb"><a href="/">Home</a> » <a href="/guyana">Guyana</a> » <a href="/guyana/announcements">Announcements</a> » <a href="/guyana/announcements/deaths-obituaries">Deaths &amp; Obituaries </a> » Celebrating The Life of Neil V.I.M. Chan, A.A.</div>		
		


		<h1 class="title">Celebrating The Life of Neil V.I.M. Chan, A.A.</h1>				<!-- main-content-block --><div class="main-content-block"> 
		<ul id="sharebar" style="background:#FFFFFF;border-color:#CCCCCC;margin-top:0px;"><li><div id="fb-root"></div> <script>(function(d, s, id) { var js, fjs = d.getElementsByTagName(s)[0]; if (d.getElementById(id)) return; js = d.createElement(s); js.id = id; js.src = "//connect.facebook.net/en_US/all.js#xfbml=1"; fjs.parentNode.insertBefore(js, fjs); }(document, 'script', 'facebook-jssdk'));</script> <html xmlns:fb="http://ogp.me/ns/fb#"> <fb:like href="http://www.guyanagraphic.com/guyana/announcements/deaths-obituaries/celebrating-life-neil-vim-chan-aa" send="true" layout="box_count" width="450" show_faces="true"></fb:like></li><li><a href="http://twitter.com/share" class="twitter-share-button" data-url="http://www.guyanagraphic.com/guyana/announcements/deaths-obituaries/celebrating-life-neil-vim-chan-aa"data-count="vertical" data-via="GuyanaGraphic">Tweet</a><script type="text/javascript" src="http://platform.twitter.com/widgets.js"></script></li></ul><ul id="sharebarx"><li><div id="fb-root"></div> <script>(function(d, s, id) { var js, fjs = d.getElementsByTagName(s)[0]; if (d.getElementById(id)) return; js = d.createElement(s); js.id = id; js.src = "//connect.facebook.net/en_US/all.js#xfbml=1"; fjs.parentNode.insertBefore(js, fjs); }(document, 'script', 'facebook-jssdk'));</script> <html xmlns:fb="http://ogp.me/ns/fb#"> <fb:like href="http://www.guyanagraphic.com/guyana/announcements/deaths-obituaries/celebrating-life-neil-vim-chan-aa" send="true" layout="button_count" width="450" show_faces="true"></fb:like></li><li><a href="http://twitter.com/share" class="twitter-share-button" data-url="http://www.guyanagraphic.com/guyana/announcements/deaths-obituaries/celebrating-life-neil-vim-chan-aa" data-count="horizontal" data-via="GuyanaGraphic">Tweet</a><script type="text/javascript" src="http://platform.twitter.com/widgets.js"></script></li></ul>  <div class="node">
    <div class="picture">
  </div>

 <span class="submitted">Submitted by Claire Ann Goring on Fri, 01/05/2018 - 10:07</span>

       
    
    <div class="content clear-block"><div class="all-attached-images"><div class="image-attach-body image-attach-node-3754" style="width: 242px;"><a href="/neil-vim-chan-aa-1970s"><img src="http://www.guyanagraphic.com/sites/default/files/images/26168393_10155124265625770_561023374178732969_n.thumbnail.jpg" alt=" Neil V.I.M. Chan, A.A. - 1970s" title=" Neil V.I.M. Chan, A.A. - 1970s"  class="image image-thumbnail " width="242" height="242" /></a></div>
<div class="image-attach-body image-attach-node-3753" style="width: 242px;"><a href="/neil-vim-chan-aa-costume"><img src="http://www.guyanagraphic.com/sites/default/files/images/26678585_10155124276535770_108152416043211047_o.thumbnail.jpg" alt=" Neil V.I.M. Chan, A.A. - In costume" title=" Neil V.I.M. Chan, A.A. - In costume"  class="image image-thumbnail " width="242" height="242" /></a></div>
<div class="image-attach-body image-attach-node-3752" style="width: 242px;"><a href="/neil-vim-chan-aa"><img src="http://www.guyanagraphic.com/sites/default/files/images/26168487_10156069040861057_5240414346093921863_n.thumbnail.jpg" alt="Neil V.I.M. Chan, A.A." title="Neil V.I.M. Chan, A.A."  class="image image-thumbnail " width="242" height="242" /></a></div>
</div><p>Neil Vibert Ignatius Michael Chan was born on November 4, 1929 to parents Solomon Chan and Ruby Beckles in Georgetown, Guyana. He had one brother Hubert and sister Patricia who both predeceased him. Neil and his devoted wife, Sheila, shared fifty-eight years of marriage based on love, devotion and mutual respect.</p>
<p>Neil Chan had many interests, including, sports, culture, music and business. As a young man, he was an ardent boxing and table tennis fan, but he excelled in the bodybuilding and weightlifting fields and later represented Guyana at the 1966 8th British Empire and Commonwealth Games in Jamaica.</p>
<p>As a businessman, he specialized in the import trade. In 1970, he was appointed the first General Manager of the External Trade Bureau (ETB), which was responsible for the importation of most of Guyana&rsquo;s food and other commodities. He played a major role in trade at a time when foreign currency was in short supply and materials for the development of the country were greatly needed.<br />
Neil Chan started Bel Park Guyana Agency in the 1970s, as distributor of the Solo brand of agricultural equipment used by small farmers throughout Guyana. His agency also collaborated with various ministries, supplying cutting-edge equipment for sea defense infrastructure and the maintenance of the electricity grid.</p>
<p>Further, Neil Chan and Solo dominated the Festival Arts of Guyana for many years as the leading private sector costume band and was well known for the splendor and pageantry of his 1000 strong Mashparaders leading the parade. Neil Chan himself won the King of the Band Competition on many occasions. He insisted that each Solo presentations should always be creative in its use of locally sourced materials. Chan later became convenor of the Mash Nite and Mash Day Competitions. Solo also participated in Deepavali Pageants with the Solo contestants displaying Saris created locally by Solo staff.</p>
<p>The Solo brand also extended to Motor Racing and Chan and the members of the Solo Super Team, racing the best available racing cars, go-carts and racing bikes, left its marks as one of the big teams in the history of Guyana Motor Racing &amp;Sports Club. Thus he made a name for himself as &ldquo;Mr. Solo&rdquo; which will always be remembered by true racing fans.</p>
<p>Neil Chan was one of the significant music entrepreneurs in the early post-independence era. In addition to Solo Sounds International, Chan was also the owner of Xanadu, a popular upscale discotheque. He grew up in the Lacytown area of Georgetown during the 1940s and 1950s and was exposed to the musical ferment taking place in this urban working-class ward during that era. In addition, he was part of the early steel band &ldquo;action,&rdquo; playing an energetic role in developing costumed bands for tramping. As a young man, he along with Billy Moore, Neville Rose, Willie Wright, and Ev Manifold were members of the standard-setting Billy Moore and the Four Lords. All these experiences lay the firm foundation for, and came to the fore in his excellence as an exponent in Guyanese expressions.</p>
<p>Chan felt that Guyanese music should be dynamic and reflective of the changes taking place internationally, especially in the United States. This meant that the best contemporary instruments and sound equipment had to be used and the music had to be original. It was in this context that Solo Sounds International emerged. Like Combo 7 and the Music Machine, Neil Chan showed his respect for the artists by paying the members of Solo Sounds International a regular monthly salary.</p>
<p>The members of the band included: Frederick Bradshaw (first trumpet); Eon Wilson (second trumpet); Owen &ldquo;Jive&rdquo; Parris (Alto Sax); Ronald &ldquo;Lally&rdquo; Greaves (Alto Sax); Lyndon &ldquo;Dudley&rdquo; Collier (Tenor Sax, Vocals); Colin Aaron (First Trombone); Terrence &ldquo;Cyrano&rdquo; Wood (Second Trombone); Lester Hunte (Guitar); Wayne Hunes (Bass Guitar); Phillip Nichols (Electronic piano, Krumar string ensemble); Derry Etkins (Synthesizer); Trevor &ldquo;TJ&rdquo; John (Drums); Aubrey Cossiah, Joey Morgan ((Percussion); Melanie King-Nunes (Vocals); Joslyn Small (sound engineer); Guy Bunbury &ndash;RIP (organ); Aubrey D&rsquo;Aguiar &ndash;RIP (Vocals); Terry King &ndash; RIP (Vocals); William &ldquo;Billy&rdquo; Van Tull, Peter Hendy (Band Manager)</p>
<p>Although Chan owned and operated Xanadu, he did not believe that Solo Sounds International&rsquo;s music should be cloistered in that venue. By the late 1970s he was active creating large public entertainment events. His mission was to &ldquo;Nice up Guyana.&rdquo; Smile Guyana was one such event. Part of this mission included bringing in international musicians, particularly acts from Trinidad and Tobago. It was through Neil Chan&rsquo;s efforts that Guyana was able to see a new generation of calypsonians from Trinidad, such as David Rudder, Tambu, the Charlie&rsquo;s Roots band and Shadow and hear the experimentations that were taking place in Soca. By the end of the 1970s, Solo Sounds International was the band that was in demand by the state sector. Because of this visibility, Neil Chan and Solo Sounds International exerted significant influence on popular music in Guyana during the 1970s and the early 1980s.</p>
<p>It was with the encouragement and support of Neil Chan that musician Derry Etkins began to experiment with the incorporation of indigenous beats and rhythms. The masquerade influences of his early childhood began to infuse his music and can be heard now in compositions and arrangements, such as the theme music for the Solo Smile Guyana project, &ldquo;Coconut Broth,&rdquo; &ldquo;Roots Walk,&rdquo; and &ldquo;Plaisance Backdam.&rdquo; Those compositions introduced the &ldquo;fish beat,&rdquo; and celebrated Guyana&rsquo;s racial and ethnic heritages. The result of these experimentations , is to be found on the LP Solo Sounds International&mdash;a limited edition LP of original compositions.</p>
<p>Neil Chan was honored by the Government of Guyana with the Golden Arrow of Achievement for his long, dedicated and outstanding contribution to Guyana&rsquo;s culture. In 2012, Neil Chan was also honored by the Guyana Cultural Association of New York with the GCA Award for his contribution to Guyana&rsquo;s Arts and culture.</p>
<p>His wife Sheila, adopted children Fabian Gaskin and Sattie Sasenarine, Carlotta, Vilma and George Chan; nephews Musa Amin and Neil Allicock, nieces Patricia Mercurius, Sandra Britton, Marcy Allicock and six others; great nieces and nephew: Michelle Britton, Tony Britton and Abbi Braithwaight and 16 others; 18 great great nieces and nephews; cousins the Chan family; cherished friends: Fay and Grant Gaskin and family, the Spooner family, Claire Goring, Alicia Dougall and family, Inez Seepaul, Jean Archer and son Frank; Robin Hunte, Lance Gasnabbi, Peter Hendy, Aloma Fredericks, Vic Persaud, Sir Shridath Ramphal, Mr. Hamilton Green, Dr. Dalgleish Joseph, Dr. Carl Hanoman, Sheila Chapman, and many others will keep his legacy alive and cherish the many memories they have of Neil V.I.M. Chan A.A.</p>
</div>
	<div class="taxonomy"><ul class="links inline"><li class="taxonomy_term_46 first"><a href="/guyana/announcements/deaths-obituaries" rel="tag" title="">Deaths &amp; Obituaries </a></li>
<li class="taxonomy_term_32"><a href="/guyana/notable-guyanese" rel="tag" title="">Notable Guyanese</a></li>
<li class="taxonomy_term_101 last"><a href="/all" rel="tag" title="">All</a></li>
</ul></div>    <div class="links">&raquo; <ul class="links inline"><li class="fb_social_like first"><span><div class="fb-social-like-widget"><fb:like  href="http://www.guyanagraphic.com/guyana/announcements/deaths-obituaries/celebrating-life-neil-vim-chan-aa" send="true" layout="button_count" show_faces="false" width="10" action="recommend" font="arial" colorscheme="light"></fb:like></div></span></li>
<li class="fb_social_send last"><span><div class="fb-social-send-widget"><fb:send  href="http://www.guyanagraphic.com/guyana/announcements/deaths-obituaries/celebrating-life-neil-vim-chan-aa" font="arial" colorscheme="light"></fb:send></div></span></li>
</ul></div>  </div>
		<!-- /main-content-block --></div>
		
        



<!-- PRINTING BLOCK AFTER THE CONTENT -->






<!-- / column-2 --></div>



<!-- column-3 -->
<div class="column-3"><div id="block--3" class="block">

  <div class="content">
    <div style='text-align:center'><div class='adsense' style='display:inline-block;width:320px;height:50px;'>
<script type="text/javascript"><!--
google_ad_client = "ca-pub-9625100032439743";
/* 320x50 */
google_ad_slot = "4616369314";
google_ad_width = 320;
google_ad_height = 50;
//-->
</script>
<script type="text/javascript"
src="//pagead2.googlesyndication.com/pagead/show_ads.js">
</script>
</div></div>  </div>
</div>
  <div class="block block-block" id="block-block-65">
   <h2 class="title">Support Guyana Graphic</h2>    <div class="content"><table style="width: 100%">
<tr>
<td style="width: 60%"><strong>If you would like to support the work of Guyana Graphic donate here</strong></td>
<td>
<form action="https://www.paypal.com/cgi-bin/webscr" method="post" target="_top">
<input type="hidden" name="cmd" value="_s-xclick" /><br />
<input type="hidden" name="hosted_button_id" value="E4EDG6XUQLSTN" /><br />
<input type="image" src="https://www.paypalobjects.com/en_US/i/btn/btn_donateCC_LG.gif" border="0" name="submit" alt="PayPal - The safer, easier way to pay online!" /><br />
<img alt="" border="0" src="https://www.paypalobjects.com/en_US/i/scr/pixel.gif" width="1" height="1" /><br />
</form>
</td>
</tr>
</table>
</div>
 </div>
  <div class="block block-simplenews" id="block-simplenews-101">
   <h2 class="title">Subscribe to our Newsletter</h2>    <div class="content">      <p>Click Link below to:</p>
  
      <p><a href="/newsletter/subscriptions">Manage my subscriptions</a></p>
  
  
  
  </div>
 </div>
<div id="block--1" class="block">

  <div class="content">
    <div style='text-align:center'><div class='adsense' style='display:inline-block;width:336px;height:280px;'>
<script type="text/javascript"><!--
google_ad_client = "ca-pub-9625100032439743";
/* 336x280 */
google_ad_slot = "4016096911";
google_ad_width = 336;
google_ad_height = 280;
//-->
</script>
<script type="text/javascript"
src="//pagead2.googlesyndication.com/pagead/show_ads.js">
</script>
</div></div>  </div>
</div>
  <div class="block block-imageblock" id="block-imageblock-53">
       <div class="content">
  <div class="block-body">
    <p><iframe width="320" height="181" src="//www.youtube.com/embed/WSOG2i75Ag4?rel=0" frameborder="0" allowfullscreen></iframe></p>
  </div>
</div>
 </div>
  <div class="block block-block" id="block-block-12">
       <div class="content"><script type="text/javascript" src="http://jj.revolvermaps.com/2/4.js?i=9862yte8cuf&amp;m=7&amp;h=160&amp;c=ff0000&amp;r=0" async="async"></script></div>
 </div>
</div>
<!-- / column-3 -->



<!-- footer -->
<div id="footer" class="clear-block">
 
  <div id="block--2" class="block">

  <div class="content">
    <div style='text-align:center'><div class='adsense' style='display:inline-block;width:728px;height:90px;'>
<script type="text/javascript"><!--
google_ad_client = "ca-pub-9625100032439743";
/* 728x90 */
google_ad_slot = "1341832114";
google_ad_width = 728;
google_ad_height = 90;
//-->
</script>
<script type="text/javascript"
src="//pagead2.googlesyndication.com/pagead/show_ads.js">
</script>
</div></div>  </div>
</div>

<div class="clear-both">
  <p>ICMBC ​&copy; 2015&nbsp;GuyanaGraphic.com. All Rights Reserved - webmaster@GuyanaGraphic.com</p>
  <div id="fb-root"></div><script type="text/javascript">
     window.fbAsyncInit = function() {
       FB.init({
         appId: "158651424149318",
         status: true, 
         cookie: true,
         xfbml: true,
         channelUrl: "http://www.guyanagraphic.com/fb_social/channel"
       });
       
       FB.Event.subscribe("edge.create", function(href, widget) {
_gaq.push(["_trackEvent", "Facebook like", "Drupal", href]);
});
       
         
     };
     (function() {
       var e = document.createElement('script'); 
       e.async = true;
       e.src = document.location.protocol + '//connect.facebook.net/en_US/all.js';
       document.getElementById('fb-root').appendChild(e);
     }());
  </script></div>

</div>
<!-- /footer -->



</div>
<!-- / make-it-center -->

	</body>
</html>